Browse Source

Update dependencies

pull/35/head
Starbeamrainbowlabs 3 years ago
parent
commit
6ddb3dfceb
Signed by: sbrl
GPG Key ID: 1BE5172E637709C2
  1. 52
      package-lock.json
  2. 10
      package.json

52
package-lock.json generated

@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
{
"name": "air-quality-mapper",
"version": "0.10.0",
"version": "0.10.3",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
@ -25,9 +25,9 @@ @@ -25,9 +25,9 @@
}
},
"@types/chart.js": {
"version": "2.7.53",
"resolved": "https://registry.npmjs.org/@types/chart.js/-/chart.js-2.7.53.tgz",
"integrity": "sha512-z4j5PWjQff3qGF+5nJIegI5b7drtGA6+XAxoAOINZYkkUuwlmBvjbGtruUAugbaxQkLcCklKZ88dZaPSnFNggg==",
"version": "2.7.54",
"resolved": "https://registry.npmjs.org/@types/chart.js/-/chart.js-2.7.54.tgz",
"integrity": "sha512-BxIUR4mfk0zOqOPEu4gxLP5herra6INQLyFmgVE6JVRNNB+r36g2cd67nDUEEdD/EShZvaR33xausxOGv1+nbw==",
"dev": true
},
"@types/chroma-js": {
@ -79,9 +79,9 @@ @@ -79,9 +79,9 @@
}
},
"@types/node": {
"version": "12.0.7",
"resolved": "https://registry.npmjs.org/@types/node/-/node-12.0.7.tgz",
"integrity": "sha512-1YKeT4JitGgE4SOzyB9eMwO0nGVNkNEsm9qlIt1Lqm/tG2QEiSMTD4kS3aO6L+w5SClLVxALmIBESK6Mk5wX0A==",
"version": "12.0.8",
"resolved": "https://registry.npmjs.org/@types/node/-/node-12.0.8.tgz",
"integrity": "sha512-b8bbUOTwzIY3V5vDTY1fIJ+ePKDUBqt2hC2woVGotdQQhG/2Sh62HOKHrT7ab+VerXAcPyAiTEipPu/FsreUtg==",
"dev": true
},
"@types/q": {
@ -420,9 +420,9 @@ @@ -420,9 +420,9 @@
}
},
"chroma-js": {
"version": "2.0.3",
"resolved": "https://registry.npmjs.org/chroma-js/-/chroma-js-2.0.3.tgz",
"integrity": "sha512-2kTvZZOFSV1O81/rm99t9vmkh9jQxsHqsRRoZevDVz/VCC3yKMyPuMK8M5yHG+UMg2tV6cRoqtZtgcD92udcBw=="
"version": "2.0.4",
"resolved": "https://registry.npmjs.org/chroma-js/-/chroma-js-2.0.4.tgz",
"integrity": "sha512-gk71qOrSdBTLbsd0DIUO3QjZL8tTvMwpG1EoXYScy7rI4rcO4EyYH6zGuvCgUDumKumqg0pt6Ua+vWnMJsTYhw=="
},
"class-utils": {
"version": "0.3.6",
@ -3688,13 +3688,13 @@ @@ -3688,13 +3688,13 @@
"dev": true
},
"rollup": {
"version": "1.14.6",
"resolved": "https://registry.npmjs.org/rollup/-/rollup-1.14.6.tgz",
"integrity": "sha512-A8f54Fms9PAG2VBLBg/XOBgN6tRQKgroltD86f+gF5+6eRmAAlFBJAFV0K7MHl2aHOCcrATWO1B8SAjVD2Ehsw==",
"version": "1.15.6",
"resolved": "https://registry.npmjs.org/rollup/-/rollup-1.15.6.tgz",
"integrity": "sha512-s3Vn3QJQ5YVFfIG4nXoG9VdL1I37IZsft+4ZyeBhxE0df1kCFz9e+4bEAbR4mKH3pvBO9e9xjdxWPhhIp0r9ow==",
"dev": true,
"requires": {
"@types/estree": "0.0.39",
"@types/node": "^12.0.7",
"@types/node": "^12.0.8",
"acorn": "^6.1.1"
}
},
@ -3766,9 +3766,9 @@ @@ -3766,9 +3766,9 @@
}
},
"rollup-plugin-node-resolve": {
"version": "5.0.1",
"resolved": "https://registry.npmjs.org/rollup-plugin-node-resolve/-/rollup-plugin-node-resolve-5.0.1.tgz",
"integrity": "sha512-9s3dTu44SKQZM/Pwll42GpqXgT+WdvO0Ga01lF8cwZqJGqRUATtD+GrP3uIzZdpnbPonEJbVasfFt80VGPQqKw==",
"version": "5.0.3",
"resolved": "https://registry.npmjs.org/rollup-plugin-node-resolve/-/rollup-plugin-node-resolve-5.0.3.tgz",
"integrity": "sha512-Mhhmf0x493xgUPEsRELnU1VM+4+WO82knWkAbZ0d2DvZQZJMbhzyQK/hqtpVscoRru1EqlK3TM1kK9ro469wPw==",
"dev": true,
"requires": {
"@types/resolve": "0.0.8",
@ -3785,9 +3785,9 @@ @@ -3785,9 +3785,9 @@
"dev": true
},
"resolve": {
"version": "1.11.1",
"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.11.1.tgz",
"integrity": "sha512-vIpgF6wfuJOZI7KKKSP+HmiKggadPQAdsp5HiC1mvqnfp0gF1vdwgBWZIdrVft9pgqoMFQN+R7BSWZiBxx+BBw==",
"version": "1.11.0",
"resolved": "https://registry.npmjs.org/resolve/-/resolve-1.11.0.tgz",
"integrity": "sha512-WL2pBDjqT6pGUNSUzMw00o4T7If+z4H2x3Gz893WoUQ5KW8Vr9txp00ykiP16VBaZF5+j/OcXJHZ9+PCvdiDKw==",
"dev": true,
"requires": {
"path-parse": "^1.0.6"
@ -3957,15 +3957,16 @@ @@ -3957,15 +3957,16 @@
}
},
"shepherd.js": {
"version": "2.9.1",
"resolved": "https://registry.npmjs.org/shepherd.js/-/shepherd.js-2.9.1.tgz",
"integrity": "sha512-gHHPvDh2v2tSKMd5gcS7Kjmeji3pyqhYn7CHyyIe7o/B0CIXs8MgDt3wC/h72Gat5433/+GtxQwqSr8oDQOpGQ==",
"version": "2.10.0",
"resolved": "https://registry.npmjs.org/shepherd.js/-/shepherd.js-2.10.0.tgz",
"integrity": "sha512-37bVD5/RTmwHA5zhX/WNsU/9U5S3FslBjZCqHI7/upuahieOr3TaOx+Jkc9TJK6HD9r8I8rQOeQSZGQbOs2kwA==",
"requires": {
"element-matches": "^0.1.2",
"lodash.defer": "^4.1.0",
"lodash.iselement": "^4.1.1",
"lodash.isobjectlike": "^4.0.0",
"lodash.zipobject": "^4.1.3",
"smoothscroll-polyfill": "^0.4.4",
"tippy.js": "^4.3.4"
}
},
@ -3991,6 +3992,11 @@ @@ -3991,6 +3992,11 @@
"resolved": "https://registry.npmjs.org/smartsettings/-/smartsettings-1.2.3.tgz",
"integrity": "sha512-IPylE5IllnSAwKoA2To1otDrs40fdaQOnxCDXwjUCwnIHPr27Z+pjGpkbQqwhObb0poDnzldpbwa+5TYK107/g=="
},
"smoothscroll-polyfill": {
"version": "0.4.4",
"resolved": "https://registry.npmjs.org/smoothscroll-polyfill/-/smoothscroll-polyfill-0.4.4.tgz",
"integrity": "sha512-TK5ZA9U5RqCwMpfoMq/l1mrH0JAR7y7KRvOBx0n2869aLxch+gT9GhN3yUfjiw+d/DiF1mKo14+hd62JyMmoBg=="
},
"snapdragon": {
"version": "0.8.2",
"resolved": "https://registry.npmjs.org/snapdragon/-/snapdragon-0.8.2.tgz",

10
package.json

@ -19,7 +19,7 @@ @@ -19,7 +19,7 @@
"homepage": "https://github.com/sbrl/ConnectedHumber-Air-Quality-Interface#readme",
"dependencies": {
"chart.js": "^2.8.0",
"chroma-js": "^2.0.3",
"chroma-js": "^2.0.4",
"d3-delaunay": "^4.1.5",
"dom-create-element-query-selector": "github:hekigan/dom-create-element-query-selector",
"event-emitter-es6": "^1.1.5",
@ -29,13 +29,13 @@ @@ -29,13 +29,13 @@
"leaflet.markercluster": "^1.4.1",
"moment": "^2.24.0",
"nanomodal": "^5.1.1",
"shepherd.js": "^2.9.1",
"shepherd.js": "^2.10.0",
"smartsettings": "^1.2.3",
"tabs": "^0.2.0",
"xml-writer": "^1.7.0"
},
"devDependencies": {
"@types/chart.js": "^2.7.53",
"@types/chart.js": "^2.7.54",
"@types/chroma-js": "^1.4.1",
"@types/d3-delaunay": "^4.1.0",
"@types/event-emitter-es6": "^1.1.0",
@ -44,10 +44,10 @@ @@ -44,10 +44,10 @@
"nightdocs": "^1.0.5",
"postcss-copy": "^7.1.0",
"postcss-import": "^12.0.1",
"rollup": "^1.14.6",
"rollup": "^1.15.6",
"rollup-plugin-commonjs": "^10.0.0",
"rollup-plugin-json": "^4.0.0",
"rollup-plugin-node-resolve": "^5.0.1",
"rollup-plugin-node-resolve": "^5.0.3",
"rollup-plugin-postcss": "^2.0.3",
"rollup-plugin-replace": "^2.2.0",
"rollup-plugin-terser": "^5.0.0"

Loading…
Cancel
Save